istanbul

0.4.5 latest

Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests

License

  • BSD-3-Clause

Published

Dependencies

14 deps 5 devDeps
low

Zero Version

  • metadata

This package version is 0.X.Y: the semver spec mandates those versions for initial development meaning that anything may change at any time and the public API of this package should not be considered stable.

low

Deprecated

This module is no longer maintained, try this instead: npm i nyc Visit https://istanbul.js.org/integrations for other alternatives.

Analysed versions

76 versions

  • 1.1.0-alpha.1

    3
  • 1.0.0-alpha.2

    3
  • 0.4.5

    3
    latest
  • 0.4.4

    3
  • 0.4.3

    3
  • 0.4.2

    3
  • 0.4.1

    3
  • 0.4.0

    3
  • 0.3.22

    1
  • 0.3.21

    3

Loaded 10 of 76

Dependencies

Backlog

19 versions

Loaded 9 of 19

Behavioural monitoring and security for npm packages

Monitor every change in your dependency tree and automatically block malicious packages from entering your codebase. Safeguard your projects by using lstn in GitHub.